Installing visualboyadvance-gtk on Ubuntu 18.04

July 23, 2018

Visualboyadvance that comes in the Ubuntu default repositories is awful. And the repos don't carry the gtk version. Luckily, the .deb from the Debian repositories works fine.

First uninstall any visualboyadvance you already have. Then install the two prerequisites, and you're golden to install visualboyadvance-gtk.

sudo apt remove visualboyadvance -y
wget http://ftp.us.debian.org/debian/pool/main/v/visualboyadvance/visualboyadvance_1.8.0.dfsg-4_amd64.deb
wget http://ftp.us.debian.org/debian/pool/main/v/visualboyadvance/visualboyadvance-gtk_1.8.0.dfsg-4_amd64.deb
sudo apt install libgtkmm-2.4-1v5 -y
sudo dpkg -i visualboyadvance_1.8.0.dfsg-4_amd64.deb
sudo dpkg -i visualboyadvance-gtk_1.8.0.dfsg-4_amd64.deb

Now you can run visualboyadvance from your application search menu or from the command line with gvba.